HK -Storefront service is down
Incident Report for LogiCommerce
Resolved
This incident has been resolved.
Posted Oct 22, 2017 - 07:14 CEST
Identified
We're experiencing severe problems in storefront servers node.
We're working on it.
Posted Oct 22, 2017 - 07:06 CEST