IR - Administrator service is down
Incident Report for LogiCommerce
Resolved
This incident has been resolved.
Posted Oct 23, 2017 - 21:18 CEST
Identified
We're experiencing severe problems in administrator servers node.
We're working on it.
The system should be caught up shortly.
Apologize for the inconvenience.
Posted Oct 23, 2017 - 20:59 CEST