Storefront service is down
Incident Report for LogiCommerce
Resolved
This incident has been resolved.
Posted Nov 11, 2017 - 09:50 CET
Identified
We're experiencing severe problems in storefront servers node.
We're working on it.
The system should be caught up shortly.
Apologize for the inconvenience.
Posted Nov 11, 2017 - 09:10 CET